Moodle 2.6

http://docs.moodle.org/26/en/Installing_Moodle にあるように,PHP 5.3.3以上,MySQL 5.1.33以上が必要。 http://docs.moodle.org/26/en/Installation_Quickstart を見てインストールする。

というだけではあまりにもなので…。

CentOS 6.xにインストールするには,yum installで,httpd,php,mysql,php-mysql,gd,php-gd,php-mbstring,php-intl,php-xmlを入れておく。MySQLサーバにするマシン(同じマシンでもよい)にはmysql-serverを入れておく。

MySQLサーバで次のSQLを打ち込む:

create database データベース名 default character set utf8 collate utf8_unicode_ci;
grant select,insert,update,delete,create,create temporary tables,drop,index,alter
    on データベース名.* to ユーザ名@localhost identified by 'パスワード';

localhostはMySQLが別マシンにあればそのマシン名を入れる。

Webサーバマシンの例えば /var/www/html/moodle にMoodleのソースを入れる。httpdがアクセスできないところに例えば /var/www/moodledata といったディレクトリを作り,ユーザhttpdに読み書きできるようにしておく。

これで http://ホスト名/moodle/ をアクセスすればインストールが始まる。

Moodle 1.9からのアップグレードは,Moodle 2.2を経由して行う。


Last-modified: 2015-03-02 (月) 13:51:45 (995d)